The following elements are required for a complete HigherL LMS experience:

  • Web Browser (Internet Explorer 5.0 or higher, MozillaFireFox 2.0 or higher, America Online 7.0 or higher, Apple Safari 1.0 or higher, or Netscape Communicator 6.0 or higher).
  • Internet Connection (minimum recommended speed of 1000 Kbps – Cable/DSL).
  • Adobe Flash Player.
  • Adobe Acrobat Reader or Alternative PDF Viewer.
  • Windows Media Player or QuickTime Player.